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Appendix A. Practical Color Management 
 

Printing a photograph can be time consuming, expensive, and frustrating without color 

management. I would typically print a photograph many times with different printer settings 

before one print would be usable. Making another copy of the print later was difficult unless the 

detailed settings for the printer had been written down. After color management was 

implemented, the first print of a photograph normally has good color and is reliably repeatable. 

In general, color management can provide more accurate and efficient preparation and display of 

images, and is valuable when working with archival images that are intended for many different 

uses over a period of decades. 

For those who want to try to avoid the expense and effort required for color management, a 

few principles can partially reduce the problems when working without color management. First, 

use only the sRGB working color space. This is relatively simple to apply because sRGB is the 

default color space for most software and hardware. Second, if images are printed on your own 

printer, use only one or two types of paper and one brand of ink cartridges. Different brands and 

types of paper and ink cartridges will produce different color results. Minimize the sources of 

variability and get to know your equipment well. Partial implementation of color management 

and the associated trade-offs are described for various topics in this Appendix.  

The basic principles of color management are simple. Electronic devices such as computer 

monitors, printers, and scanners can handle a limited range of colors, and the ranges are 

different for different types, brands, and models of devices. Many inkjet printers can print a 

wider range of colors than a computer monitor can display. Certain models of monitors and 

printers can handle wider ranges of colors than other models. Also, differences in manufacturing 

and wear make each individual device handle colors differently. In addition, as described in 

Chapter 2, digital processing of color requires a working color space that specifies the range of 

colors that can be handled for a digital image and how the numbers in the image are mapped to 

colors. The working color space must be assumed if it is not explicitly specified. 

The requirements for a full color management system are: 

• Each device such as a monitor, printer, or scanner has a device profile that specifies the 

range of colors the device can handle and the adjustments in color needed to make that 

specific device match standard colors. 

• The software for processing colors needs to be able to: 

o Process colors using the assigned working color space and relevant device profiles, 

including handling colors that are outside the range of a working color space or 

device;  
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o Write information about the assigned working color space to output image files, and 

read information about the assigned working color space from input image files; 

o Convert between working color spaces, including handling colors that are outside the 

range of a color space.  

Color management can be partially implemented. For example, Adobe Photoshop CS and 

Photoshop Elements can be used to manage working color space without using custom profiles 

for a monitor or printer. Or, a custom profile could be used for a monitor, but not for a printer. 

Partial implementation of color management may be adequate for images with limited uses, or 

when a device provides good color without a custom profile. 

Color management is currently complicated in practice because many software programs do 

not properly implement all the requirements for color management. Unfortunately, software 

marketing usually does not clearly describe the partial or limited implementation of color 

management. Discovering which functions are not properly implemented can be a trial and error 

process. Several examples are described in this Appendix and in Appendix B on scanning 

software.  

Implementation of color management is improving and can be expected to become more 

consistent and automatic. At some point in the future, color management for the most part will 

be reliably handled in the background. Images that are intended for many uses over the next 50 

years should be developed in a way that anticipates the increasing role of color management. 

The factors to consider when choosing a working color space are discussed in Chapter 2. The 

most common working color spaces for archival purposes are Adobe RGB (also called Adobe RGB 

1998) and sRGB for color images and Gray Gamma 2.2 for grayscale images. 

A.1 Terminology 

Several terms are important when working with color management. 

• The terms color space and gamut both refer to a range of colors and can be used 

interchangeably for the practical purposes of this book. 

• A device color space specifies the range of colors that a particular device can read or 

display. 

• The working color space specifies the range of colors that can be used when storing and 

modifying a digital image, and does not depend on any specific device.  

• For color management, a profile is actually an ICC profile that uses standards developed 

by the International Color Consortium (ICC) to specify a device color space or a working 

color space. There are two types of profiles, matrix and lookup table. 
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• Matrix profiles use equations to specify the color model and are typically used for 

monitors, working color spaces, and sometimes for scanners. Matrix profiles are small in 

size. 

• Lookup table (LUT) profiles use tables and equations to specify many details about the 

color model and are typically used for printers and sometimes for scanners. LUT profiles 

are much larger in size than matrix profiles. 

• A color is out of gamut when the color is outside the range of colors for a device or for a 

working color space. 

A profile is used for the working color space as well as for each device. A digital image 

created by a scanner must be converted to the working color space. The device profile for the 

scanner and the profile for the working color space are used to make this conversion. Similarly, 

when an image is displayed or printed, the profile for the monitor or printer and the profile for 

the working color space are used to convert the image for output.  

Image-processing software often assigns working color space by having the user specify the 

name of the computer file that has the sRGb or Adobe RGB profile. Unfortunately, this makes it 

easy for a user to incorrectly specify the profile. The various profiles for devices and working 

color spaces are usually kept in the same system folder on a computer and are listed together. 

Inconsistent use of the term calibration can be a source of confusion with color management. 

Some writings use calibration to mean adjusting the hardware settings of a device before 

creating the color profile. These writings use the term profiling for the process of creating a color 

profile. Other writings use the term calibration to include both adjusting the hardware settings 

and creating the profile for a device. This distinction is most relevant for computer monitors. The 

hardware settings for brightness and contrast should be adjusted before the profile is created. A 

person needs to determine from the context how the term calibration is being used in a given 

situation. 

A.2 Converting between Color Spaces 

When converting an image from one color space to another, out of gamut colors must be set 

to appropriate colors within the destination color space. Out of gamut colors can occur when 

converting between a working color space and a device color space or between different working 

color spaces. The optimal strategy for handling out of gamut colors depends on the nature and 

purpose of the image and the extent of out of gamut colors.  

Four different rendering intents or strategies for converting color spaces have become 

standard options in color management.  
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• Relative colorimetric is a good default or starting point for working with historical 

photographs. It is optimal for images with few out of gamut colors or when the out of 

gamut colors are not important. Relative colorimetric places high priority on maintaining 

color accuracy for colors that are in both the source and destination color spaces. Colors 

that are out of gamut are converted to the closest color in the destination color space. If a 

range of out of gamut color shades are present, this strategy tends to convert or clip 

different color shades into one color—which is a loss of color information.  

• Perceptual is useful for historical photographs in cases when relative colorimetric does not 

work well. It is intended for photographs that have many colors that are out of gamut for 

the destination color space. This rendering intent attempts to maintain a range of color 

shades for colors that are out of gamut, but it achieves this by shifting colors that are in 

gamut. A color space with a larger range of colors is compressed throughout to fit within 

a smaller color space. It attempts to make a better overall appearance by compromising 

color accuracy for colors that are in both the source and destination color spaces.  

• Absolute colorimetric is sometimes optimal for images of historical documents that are 

limited to only a few colors, but it does not work well with photographs or other cases 

with many different colors. This rendering intent goes further than relative colorimetric 

in attempting to maintain the original colors. It does not map the white point of the 

source color space to the white point of the destination color space, as is done with 

relative colorimetric.  

• Saturation has little use with historical images. It attempts to enhance color saturation 

and is sometimes used for graphs and charts, but is not appropriate for photographs. 

Note that relative colorimetric produces no distortion if there are no out of gamut colors in 

the image. On the other hand, the perceptual rendering intent shifts colors to adjust for out of 

gamut colors whether or not any out of gamut colors are actually present in the image.  

Relative colorimetric is the preferred rendering intent for cases when it can be used and is 

usually appropriate for images that originate from faded historical items. It is the default 

rendering intent for Adobe software. However, perceptual rendering intent is often used as the 

default when many images have significant out of gamut colors and are processed without 

adjusting rendering intent for individual images. The perceptual rendering intent is most 

appropriate for images with bright saturated colors. 

In practical terms, my experience has been that the difference between perceptual and 

relative colorimetric rendering intents is not noticeable for typical historical photographs with 

many different colors. However, for images with a limited range of colors, such as certificates or 

similar documents, relative colorimetric and sometimes absolute colorimetric can produce 
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significantly more accurate prints. As discussed below, the choice for rendering intent is most 

applicable, and often only applicable, when making prints. 

A.3 Misleading Rendering Intent Choices 

The perceptual and saturation rendering intents are not applicable when the source and 

destination profiles are both matrix profiles—as occurs when converting between working color 

spaces or converting from a working color space to a monitor profile. Only relative and absolute 

colorimetric rendering intents are used with matrix profiles. Relative colorimetric is the assumed 

default. Color space conversions between matrix profiles are limited to colorimetric rendering 

intents even when image-processing software appears to give the option to specify other 

rendering intents (Fraser, Murphy, and Bunting, 2005, page 103; Upton, 2007). I do not know of 

any software that gives a notice or warning message that a selected rendering intent will not be 

used when converting between matrix profiles.  

Color profiles with lookup tables may or may not contain information for all rendering 

intents. Separate tables within the profile have the data for different rendering intents, and 

tables may be included for only one or two rendering intents. Here too, image-processing 

software often gives the impression that any rendering intent can be used without providing any 

notice or warning that an alternative rendering intent will actually be used. 

A choice of rendering intents is truly available when the source and/or destination profiles 

have lookup tables for different rendering intents. The profiles for printers typically have lookup 

tables for all rendering intents. Scanner profiles can be either matrix or lookup table profiles, and 

rendering intent options vary. As described in Section A.15 below, the free PhotoME program 

(Duttke, 2009) can be easily used to determine whether a color profile is a matrix or lookup 

table profile, and what rendering intents are provided. 

One easy way to determine whether rendering intent has any effect with image-processing 

software is to compare the same image created or converted with different rendering intents. In 

Photoshop CS or Photoshop Elements, put one image on a layer overlaying the same image made 

with a different rendering intent. (With both images open in Photoshop, click on one image to 

make it active, tap Ctrl-A and Ctrl-C to make the copy, click on the other image, tap Ctrl-V to 

paste the copied image into a new layer.) Then set the blending mode to Difference (using either 

the pick-list or Alt-Shift-E). Any area that is not completely black indicates a difference in color 

between the two images. The differences between the perceptual and relative colorimetric 

rendering intents will usually be faint but visible with this method if a profile has lookup tables 

for different rendering intents. 

http://www.colorwiki.com/wiki/Color_Management_Myths_21-25�
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If the images are out of alignment this difference comparison will show edges in the images. 

The images can be aligned in Photoshop by activating the move tool by clicking the icon on the 

left tool bar or by taping V. Once the move took is activated, tapping an arrow key moves the 

image one pixel at a time in the direction of the arrow. Edges can also appear if there are 

different degrees of sharpness in the two images. This method for comparing differences can be 

used for evaluating a variety of different effects or processes. 

A.4 Writing Working Color Space Information to Output Files 

Embedded Profiles 

The standard and most reliable way to specify the working color space for an image is to 

embed the working color space profile in the output file. This is the standard practice for color 

management and is highly desirable for historical images that are intended for many uses over 

decades. Software enabled for color management expects and uses the embedded profile when 

processing the image. The profile for Adobe RGB is only about 550 bytes, which does not 

significantly alter the size of the output file. The profile for sRGB is about 3000 bytes and 

increases the output file size accordingly.  

The PhotoME program described in Section A.15 below can be used to identify whether a 

profile is embedded in an image file and which color space the profile implements. The tab for 

ICC Profile is not present for files without an embedded profile.  

EXIF Metadata 

Information about the working color space can also be specified in the standard EXIF 

documentation fields within a TIFF or JPEG image file. The EXIF documentation or metadata 

includes a field for color space. This field displays “sRGB” (or the number 1) when the working 

color space is sRGB. It displays “Uncalibrated” (or 65535 or -1) if another color space is 

specified, or sometimes if the color space is unknown. Therefore, the field indicates Uncalibrated 

if the working color space is Adobe RGB. In a work environment where the only options are 

sRGB and Adobe RGB, the EXIF field can be used to deduce the color space. If other color spaces 

are sometimes used, the EXIF field provides incomplete information. The EXIF fields can add 

several thousands of bytes or more to the size of an image file and are not required. 

EXIF color space information can be very useful because it is readily accessible from a variety 

of software, including the Windows operating system. The EXIF data can answer the key 
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question of whether an image file is in the sRGB color space and therefore is suitable for use on 

the internet and by most commercial printing services. EXIF information can be displayed with 

the Windows operating system by right-clicking on an image file, selecting “Properties”, and then 

clicking the Details tab. The field for Color Representation indicates whether the working color 

space is sRGB. Photoshop CS and Photoshop Elements display the EXIF information by clicking 

the dropdown menu Files> File Info and then the tab labeled Camera Data. IrfanView displays 

EXIF information by clicking the dropdown menu Image> Information. 

The free PhotoME program displays EXIF data and other internal metadata for an image as 

well as information about embedded profiles. The EXIF information is under the tab and section 

for Camera. The program can also be used to edit EXIF data. As described below, Photoshop CS 

and Photoshop Elements can be set to notify the user that an unexpected working color space 

profile or no profile has been found when an image file is opened. Also, in Photoshop CS or 

Photoshop Elements the name of the working color space can be displayed on the left on the 

bottom frame of the image display. The little horizontal triangle icon may need to be clicked so 

the display can be set to “Document Profile.”  

In addition to the EXIF field for color space, some images have a field for 

InteroperabilityIndex or Interoperability Identification that is set to “R98” for the sRGB color space 

and “R03” for Adobe RGB. This field can be seen with the PhotoME program and can be used by 

software such as Photoshop to identify working color space when no profile is embedded. At the 

time of this writing, this field is not displayed by the Windows operating system and is most 

frequently present in image files from cameras. 

A.5 Color Space Information for Archival Images 

As specified in Chapter 2, best practice for historical master image files is to include both an 

embedded profile and EXIF color space field. Good practice is to include either the embedded 

profile or the EXIF color space field. Both of these are handled by the software creating the 

output image file. The software for the Nikon Coolscan 5000 scanner is an example of an 

unfortunate situation that incorrectly outputs the EXIF color space field as sRGB when the actual 

color space is Adobe RGB. A person in the future who checks the EXIF information to see if the 

working color space is sRGB for use on the internet or for commercial printing would get 

incorrect information that could cause problems. The PhotoME program is the easiest way to 

identify problems like this. Image-editing software is the easiest way to correct such problems.  

Including color space information in files derived from the master images is also good 

practice, particularly when the files may be shared over a period of decades. There is some 

debate about whether embedded profiles and EXIF data are needed and worth the larger file size 

http://archivehistory.jeksite.com/chapters/chapter2.htm�


A-8 
 

for images specifically for the internet. These images should always have sRGB as the working 

color space, and the majority of current internet software assumes this without reading an 

embedded profile. The cumulative effect of larger file sizes from embedded sRGB profiles and 

EXIF data for many image files can adversely affect the functioning of a website. This rationale 

may be appropriate for image files that are intended to be displayed for a few years or less with 

limited uses, but embedded profiles and EXIF data are appropriate for files that are intended to 

be distributed for different uses over a period of several decades. 

A.6 Profiles for Computer Monitors 

Computer monitors are the greatest source of variability when working with colors. Different 

monitors display colors differently, and the display of colors changes over time for a given 

monitor. An image carefully adjusted for color using a monitor that does not accurately show 

colors will display different colors on another monitor or on a printer. Managing color for a 

computer monitor is a basic step for color management. Generic color profiles come with most 

monitors and are used by default. 

The best method to manage color on a monitor is to create a custom profile using a device 

that measures the light from the monitor. A software program displays certain specific colors on 

the computer screen and the colorimetric device plugged into a USB port reads the colors that 

are actually displayed. The software then builds a profile for adjusting colors and sets the 

operating system to use the profile. The software guides the user through the entire process and 

can include setting the brightness and contrast for the monitor prior to creating the profile. The 

less expensive systems for profiling computer monitors include X-Rite i1 and ColorVision Spyder 

($70 - $120 for a basic system). 

The Windows 7 operating system includes a less effective method to calibrate a monitor. This 

method requires that the user make visual comparisons of certain test displays on the monitor. As 

noted in the Windows 7 help information, the devices and software described above provide 

significantly better results than this more subjective process. However, this process is preferable 

to making no effort to adjust colors on the monitor. Searching the Windows 7 help information 

for “calibrating your display” will bring up the instructions for this process. 

The most common recommendation is to calibrate and profile a flat screen monitor about 

every month in order to provide continuous optimal performance. If precise handling of color is 

critical, weekly or even daily calibration and profiling is sometimes recommended. 

One point that is often confusing is that part of the color corrections in the monitor profile 

are applied to everything displayed by the monitor and part of the corrections are applied only 

by software that implements color management. The typical monitor profile has a lookup table 
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(LUT) with gamma settings that make corrections for overall colorcasts and brightness. The LUT 

corrections are loaded on the video card and applied to everything displayed on the monitor. 

However, the specific conversion of an image from a working color space to the color space for 

the monitor is only done by software that includes color management processing. With current 

software practices, the image-processing software manages this conversion, not the operating 

system.  

Image-processing software such as Photoshop Elements, Photoshop CS, SilverFast, and 

IrfanView include options to read the operating system information to determine the default 

monitor profile. These programs automatically use a custom profile if that is the default for the 

operating system. Software such as VueScan, Nikon Scan, and XnView rely on the user to 

determine the appropriate monitor profile and to enter the file name in a configuration field for 

the software. A default profile such as sRGB will be used if a custom profile is not specified. 

Some other image-processing software completely ignores the possibility of a custom monitor 

profile.  

Methods for determining how different software handle color management and further 

information on applying the LUT for a monitor profile are provided in the later sections A.15 and 

A.16. 

A.7 Profiles for Printers 

Color printers are more consistent and stable than monitors, but profiles are needed to adjust 

for manufacturing differences and for different types of paper and ink cartridges. Paper and ink 

are major sources of variation for printer output. A printer profile is built for a specific brand and 

type of paper used with a specific brand and type of ink cartridges.  

The manufacturers of printers and printing paper increasingly offer profiles for specific 

combinations of printer model, paper, and ink. My experience with these profiles was 

unfavorable a few years ago, but they may have been improved since then and may be adequate 

for some purposes. In general, I expect that custom profiles for a specific printer will give better 

results and that is my standard practice. 

The easiest way to obtain custom printer profiles is to use a printer profile service. Many such 

services can be found on the internet. A special image file is downloaded from the website of the 

profile service. The printer to be profiled is set with the paper and ink for the profile and all 

printer adjustments to the output are turned off. Then the downloaded image file is printed with 

no modifications, and the paper print mailed to the profile service. The profile service has 

equipment that reads the printed colors and develops the profile, which is then sent to the 
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purchaser. The costs for purchasing a profile from a service are in the range of $25 to $35 at the 

time of this writing. 

Another option is to purchase the equipment to make the printer profiles. That is 

considerably more expensive, but may be cost effective if many printers and profiles are 

involved. 

A third option is to purchase a profiling package that uses a scanner to develop profiles for 

printers. A color profile is first developed and implemented for the scanner. Then a special target 

image file is printed on the printer and the print is scanned. The software develops the profile for 

the printer from the scanned image. This strategy is less expensive than purchasing the 

equipment to read the colors from a print, but it is also generally considered less accurate. 

Many printers are reported to have stable color processing for years and that has been my 

experience, but some printers apparently have noticeable changes that require new profiles. 

Some of these changes are probably actually due to changes in the manufacturing of the paper or 

ink. A practical strategy is to use a profile as long as there are not noticeable problems. Those 

who want to assure the very highest quality of printing may follow recommendations to check or 

generate new profiles every 6 months or every year. 

The applicability of a profile for different paper, ink, or software can be checked by 

comparing prints. For example, a profile created for one type of glossy paper may work well with 

another type of glossy paper. A special target image and a few typical images could be printed 

with both types of paper and compared. A careful visual comparison will probably be adequate in 

most cases. A similar strategy can be used for changes to a printer, such as comparing prints 

before and after an update to the printer driver or installation of a new computer. 

A.8 Profiles for Scanners 

Profiling a scanner is not necessary for some historical projects. Good quality scanners 

usually provide relatively consistent color results using default color profiles. Adjustments during 

scanning to compensate for fading of a historical item will typically be greater than the 

adjustments resulting from a custom color profile for the scanner. Also, profiles are basically 

impossible to develop for scanning negatives because of the variability of film type and exposure 

for negatives.  

When precise handling of color for historical items is needed, a color reference target placed 

in the image is the most reliable and precise method of assuring color accuracy over the long 

term. The use of reference targets was discussed in Chapter 2. Color management makes image 

processing more efficient in these cases, but does not replace the long term reliability and 

precision of a color target. 
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A custom scanner profile may be beneficial for certain scanners and for historical projects 

that have the goal of capturing the exact condition of the item at the time of scanning without 

adjustment for fading. Also a custom color profile is needed if the scanner is used to make printer 

profiles. Another rationale for using a custom scanner profile is that making the profile is easy. It 

usually makes colors more accurate to some degree, and there is no good reason not to do it. The 

targets and software to make custom scanner profiles sometimes are bundled with a scanner, or 

can be purchased separately. The VueScan and SilverFast scanning software include options to 

easily build scanner profiles from certain targets that can be obtained separately. In addition, 

other profiling software such as X-Rite Monaco EZColor can create custom profiles for scanners. 

A custom profile for a scanner is made by scanning a special target that has known colors. 

Software then processes the scanned image to determine the adjustments needed to make it 

match the target. Targets can be obtained as reflective paper and as slides. Separate profiles are 

needed for scanning paper and slides. Some authorities recommend that a separate profile be 

made for different brands and types of slide film, particularly for Ektachrome and Kodachrome. 

However, other authorities report that a good profile works well with different types of film 

(Fraser, Murphy, Bunting, 2005, page 150). They note that the scanner profile addresses the way 

the scanner responds to color, not how particular film stock and dyes display color. A scanning 

target comes with a target description or data file that the profiling software uses to precisely 

identify the colors in the target. Some scanner profiles are matrix profiles and others are lookup 

table profiles. 

Many writers point out that a scanner profile produces optimal results only when the scanner 

is used with the same settings as when the profile was created. Any alterations of exposure or 

other adjustments compromise color accuracy. The usual recommendation is to capture the 

scanned image with no adjustments and to make adjustments in a later step with image-editing 

software.  

However, adjustments alter colors whether they are done at the time of scanning or in a later 

step. The normal assumption is that some adjustments will be needed. The adjustments 

described in Chapters 2 and 3 are appropriate for historical archives and can be done either at 

the time of scanning or in a later step.  

Appendix B includes summaries of color management capabilities and limitations for 

common scanning software. Key points include that VueScan only implements color profiles 

made with VueScan, and the color management settings that seem obvious for SilverFast result 

in an output file with the profile for the printer embedded rather than the profile for the working 

color space. The Guidance on Using Scanning Software 

at http://archivehistory.jeksite.com/chapters/scan_part1.htm provides more detailed 

http://archivehistory.jeksite.com/chapters/scan_part1.htm�
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information on applying color management with specific scanning programs. The descriptions 

include making custom scanner color profiles.  

A.9 Profiles for Cameras 

For copy stand work, including a color reference target in an original image as described in 

Chapter 2 is the most reliable and precise method to assure accurate handling of colors. Also, as 

with scanners, the use of custom color profiles is often unnecessary for making digital images of 

faded historical items.  

Color profiles are much more difficult with cameras than for scanners. A color profile for a 

camera is based on specific camera settings and controlled light sources. That may be possible in 

certain highly controlled studio situations; however, the vast majority of uses of a camera are 

under conditions that are much too diverse and dynamic for effective application of a custom 

profile. The large number of variables in the processing of color in a digital camera makes 

developing a color profile complex. Different profiles are needed for different conditions, and a 

relatively minor change in camera settings can alter the applicability of a profile.  

A.10 Color Management with Photoshop Elements 

Input Files 

If an input file has an embedded profile, Adobe Photoshop Elements 9 uses the embedded 

profile as the working color space for the image. The name of the working color space can be 

displayed on the left on the bottom frame of the image display. The little horizontal triangle icon 

may need to be clicked and the display set to Document Profile. It is wise to display the name of 

the embedded profile if different images have different profiles.  

For an image file without an embedded profile, a working color space can be assigned as the 

file is opened. Color images can be assigned either sRGB or Adobe RGB, and grayscale images 

can be assigned Gray Gamma 2.2. Photoshop Elements can be set to assign a certain profile to all 

input images without a profile, or the user can be asked for each input file without a profile. This 

option is set using the dropdown menu Edit> Color Settings. The safest option is to ask for each 

file. Note that this assignment is intended to specify the color space that was used to make the 

image and does not change or convert the numeric color values in the image.  

Photoshop Elements also has an option for whether the EXIF color space field and the 

InteroperabilityIndex field are used to determine working color space when a profile is not 
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embedded in an input file. This option is set with the checkbox “Ignore Camera Data (EXIF) 

profiles” under the dropdown menu Edit> Preferences> Saving Files. An embedded profile has 

priority if one is present. 

Color Spaces in Photoshop Elements 

The working color space can be converted to either sRGB or Adobe RGB. These are the only 

two conversion options in Photoshop Elements. Conversion of working color space is done with 

the dropdown menu Image> Convert Color Space. This conversion actually changes the numeric 

color values for the image to fit the new color space. Because working color space is a matrix 

profile, the relative colorimetric rendering intent is used for these conversions. 

Photoshop Elements uses the monitor profile that is specified by the operating system as the 

default profile and will use a custom profile if that is the default. No special steps within 

Photoshop Elements are needed to use a custom profile for the display monitor.  

Printing 

Color management for printing is applied by opening the print dialog box (File> Print) and 

clicking the More Options button. Then click on Color Management in the column on the left. Set 

the field for Color Handling to “Photoshop Elements Manages Colors.” It is almost always better 

to have Adobe products handle color for printing. The field for Printer Profile should be set to the 

custom profile for the printer or to a profile for the specific printer and type of paper if a custom 

profile is not used. The field for Rendering Intent specifies the rendering intent for the 

conversion of the image from the working color space to the color space for the printer profile. 

As discussed above, the rendering intent typically will be set to Relative Colorimetric or to 

Perceptual.  

The Photoshop Elements printer dialog box includes a note that color management needs to 

be turned off in the printer configuration when Photoshop Elements is managing color for 

printing. If this is not done, color conversions may be applied by both Photoshop Elements and 

the printer, which causes color distortions such as a reddish color cast and/or over saturated 

colors. The button for Printer Preferences can be clicked to open the controls for the printer. The 

color management options on the printer should include an option for none or disabled. Click Ok 

to return to the main print dialog box. The settings on the printer for type of paper and quality of 

printing may need to be set, which can be done by clicking the button for Change Settings in the 

section for Printer Settings in the Photoshop Elements printer dialog box. 
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Output Files 

Including the profile for the working color space in an output file is an option on the usual 

Save As dialog box from the dropdown menu File> Save As. When the checkbox for “ICC Profile” 

is checked the output file will include the profile. The name of the actual profile that will be 

included is listed by the checkbox. If a profile is embedded in the output file, the EXIF field for 

color space will be handled correctly in the output file. However, if a profile is not embedded, 

the EXIF field for color space will be set to Uncalibrated even if the working color space for the 

image was sRGB. This can be misleading for future use of the output file. 

A.11 Color Management with Photoshop CS 

Input Files 

In Adobe Photoshop CS, default working color spaces are specified for color and grayscale 

images. If an input file has an embedded profile that is different than the specified default, 

Photoshop CS can be set to automatically use the embedded profile as the working color space or 

to automatically convert the image to the default working color space. Alternatively, Photoshop 

CS can be set to ask the user to verify the handling of the image. The latter is the safest practice. 

These options are set using the dropdown menu Edit> Color Settings.  

If an input image does not have an embedded profile, the image can be opened and 

processed as “untagged” (not having a profile), or the user can be asked whether to assign a 

profile to the image. Asking the user is the better practice by far. The user can specify a working 

color space to assign. This assignment is intended to specify the color space that was used to 

make the image and does not change or convert the numeric color values in the image. In 

addition, the user can check a checkbox that will cause the image to be converted to the default 

working color space from the assigned working color space. The option to ask the user is set with 

the dropdown menu Edit> Color Settings. Make sure the checkbox for “Missing Profiles” is 

checked.  

Photoshop CS also has an option for whether the EXIF color space field and the 

InteroperabilityIndex field are used to determine working color space when a profile is not 

embedded. This option is set with the checkbox “Ignore EXIF Profile Tag” under the dropdown 

menu Edit> Preferences> File Handling. The EXIF information is used if this checkbox is 

cleared. There is no warning that the EXIF information is used rather than an embedded profile. 

An embedded profile has priority if one is present. 
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Color Spaces in Photoshop CS 

The name of the working color space for an image can be displayed on the left on the bottom 

frame of the image display. The little horizontal triangle icon may need to be clicked and the 

display set to Document Profile.  

The working color space can be converted to any other working color space. Conversion of 

working color space is done with the dropdown menu Edit> Convert to Profile. This conversion 

actually changes the numeric color values for the image to fit the new color space. The 

checkboxes for “Use Black Point Compensation” and “Use Dither” are normally set as checked. 

The options include selecting the rendering intent for the conversion; however, as noted earlier, 

the matrix profiles for working color space will use relative colorimetric even if another 

rendering intent is selected here. 

Photoshop CS uses the monitor profile that is specified by the operating system as the default 

profile. A custom profile will be used if that is the default. No special steps within Photoshop CS 

are needed to use a custom profile for the display monitor.  

Printing 

The options for printing with color management are on the main print dialog box (File> 

Print). Set the field in the upper right to “Color Manage” and set the field for Color Handling to 

“Photoshop Manages Colors.” The field for Printer Profile should be set to the custom profile for 

the printer or to a profile for the specific printer and type of paper if a custom profile is not used. 

The field for Rendering Intent specifies the rendering intent for the conversion of the image from 

the working color space to the color space for the printer profile. As discussed above, the 

rendering intent typically will be set to Relative Colorimetric or to Perceptual. The checkbox for 

Black Point Compensation is normally checked and assures that the full range of tone will be 

printed.  

The print dialog box includes a note that color management needs to be turned off in the 

printer configuration when Photoshop CS is managing color for printing. If this is not done, color 

conversions may be applied by both Photoshop CS and the printer, which causes color distortions 

such as a reddish color cast and/or over saturated colors. The button for Print Settings can be 

clicked to open the controls for the printer. The color management options on the printer should 

include an option for none or disabled. Click Ok to return to the main print dialog box. The 

printer settings for type of paper and quality of printing may need to be set, which can be done 

by clicking the button for Change Settings in the section for Printer Settings on the Photoshop CS 

printer dialog box. 
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The checkboxes for Match Print Colors, Gamut Warning, and Show Paper White pertain to 

how the image is displayed in the print dialog box and can all be checked. 

Output Files 

Including the profile for the working color space in an output file is an option on the usual 

Save As dialog box from the dropdown menu File> Save As. When the checkbox for “ICC Profile” 

is checked the output file will include the profile. The name of the actual profile that will be 

included is listed by the checkbox. If a profile is embedded in the output file, the EXIF field for 

color space will be handled correctly in the output file. However, if a profile is not embedded, 

the EXIF field for color space will be set to Uncalibrated even if the working color space for the 

image was sRGB. This can be misleading for future use of the output file. 

Soft Proofing  

The soft proofing feature in Photoshop CS can be very useful in understanding and 

anticipating the color changes when an image is converted to a device or working color space. 

Soft proofing attempts to display on the computer monitor the changes that will occur with the 

conversion. To the extent possible, this display compensates for the limitations of the monitor, 

but, of course, the comparison is not perfect. Soft proofing is setup from the drop down menu 

View> Proof Setup. The preset values that can be selected include “Internet Standard RGB 

(sRGB)” and “Legacy Macintosh RGB (Gamma 1.8).” These display the image as it would be 

displayed on a Windows or Macintosh computer without color management, as will typically 

occur for files on the internet.  

The Custom soft proofing option brings up a dialog box that allows display of out of gamut 

colors, different rendering intents, and lack of proper color management. Any profile on the 

computer system can be used for soft proofing, including custom printer profiles and different 

working color spaces. The checkbox for Preserve RGB Numbers is a key option. When this is 

checked, the soft proof displays the image as it would appear if it was displayed without proper 

conversion to the new profile. For example, the soft proofing profile can be set to sRGB to display 

how an image with Adobe RGB working color space will appear if it is displayed or printed 

without color management—as often occurs with images on the internet. When the checkbox is 

cleared, the soft proof image is displayed with conversion of the color space. The results with 

different rendering intents can be examined, but as noted earlier, rendering intent has no effect 

for matrix profiles such as working color space. The checkbox for Black Point Compensation can 

be checked if that would be used on the actual final conversion. The checkboxes for Simulate 
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Paper Color and Simulate Black Ink are sometimes checked if the soft proofing is for a print on 

paper, but these also often give misleading results.  

After the soft proof has been setup, activate the soft proof display by tapping Ctrl-Y or using 

the dropdown menu View> Proof Colors. When soft proofing is finished, be sure to turn it off or 

inappropriate adjustments may be made to the image. The name of the profile for soft proofing is 

included in the title at the top of the image frame when soft proofing is active. 

Out of gamut colors can be displayed during soft proofing by tapping Ctrl-Shift-Y or by using 

the dropdown menu View> Gamut Warning. By default areas of the image that have out of 

gamut colors are displayed as gray. The color can be changed to something more conspicuous by 

changing the gamut warning color under the dropdown menu Edit> Preferences> Transparency 

& Gamut. After an area with out of gamut colors is identified, turn off the gamut warning and 

use Ctrl-Y to toggle soft proofing on and off. This can give an idea of the color that is being used 

to replace the out of gamut color, although it must be remembered that soft proofing is limited 

by the color space of the display monitor.  

A.12 Color Management with IrfanView 

The free IrfanView image-viewing program was noted in Chapter 4 as useful for browsing 

images and associated text documentation files, and is also useful for lossless JPEG operations as 

described in Appendix E and for certain types of slide shows as described in Appendix F. 

IrfanView can use embedded color profiles and a monitor profile to display an image—which is 

the main purpose of the program.  

Color management is turned on in IrfanView with the dropdown menu Options> View. Place 

a check in the checkbox for “Enable color management, set display/output color profile 

(plugin).” The LCMS plug-in must be installed for IrfanView to used color management. This 

plug-in is available on the IrfanView website. The radio button for “Current monitor profile” will 

normally be selected to use the profile that is the default for the operating system. Alternatively, 

the field for “Custom ICC/ICM RGB profile file” can be used to specify a specific profile for the 

monitor.  

A default color profile can be assigned for an image file without an embedded profile by 

checking the checkbox for “Apply also for images without embedded color profile (slow!), set 

ICC profile.” A field specifies the path and file name for a profile to use for files that do not have 

an embedded profile. The specified profile will be used for any file without an embedded profile. 

There is no option for notification or verification by the user, and the EXIF color space data is not 

considered. The operating system folder with the profiles must be known to assign a profile. The 
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location of this folder is given in the next section. As indicated by the slow warning, IrfanView 

displays images more slowly when color management is active. 

IrfanView can modify and save images, but that is not recommended for archival work. An 

output image saved with IrfanView uses the monitor profile as the working color space and does 

not have an embedded profile or EXIF information about the working color space. An image file 

that is viewed without saving is not changed. Likewise, an image that is renamed without other 

modification is not changed. The lossless JPEG operations do not change the handling of tone 

and color for the image.  

A.13 Selecting Color Spaces and Profiles 

As noted in chapter 2:  

• sRGB (also known as sRGB IEC611966-2.1) color space is optimized for display on 

computer monitors and is the default working color space for most software and 

hardware. It is used for images on the internet and for most commercial printing services, 

and has a relatively small range of colors.  

• Adobe RGB (also known as Adobe RGB 1998 or aRGB) color space is optimized for 

printing and has more tones in the yellow-orange and particularly the blue-green color 

ranges than sRGB. Use of Adobe RGB requires careful color management at every step of 

processing and does not provide noticeable improvement for the great majority of 

images. 

• Gray Gamma 2.2 color space is a grayscale color space that is generally considered 

optimal for display on computer monitors, for printing with inkjet printers, and for 

archival images. 

If an image with Adobe RGB working color space is incorrectly printed as if it were sRGB, the 

colors appear significantly flat and washed out. If a sRGB image is printed incorrectly as Adobe 

RGB, the colors appear over saturated. 

Other working color spaces are available, but their reliability for use over the long-term is 

questionable. The color spaces noted above are appropriate for historical archives that meet the 

criteria for this book of being reliably accessible at least 50 years in the future. Also, color spaces 

with a wider range of colors than Adobe RGB should normally be used with a bit depth of 16 bits 

to provide adequate resolution for the additional color tones. 

For computers with Windows 7 or Windows XP, the color profiles are located in the folder 

C:\Windows\System32\spool\drivers\color. Each profile is in a separate file and the file name 

usually indicates the profile. The profile files have the file name extension .icc or .icm. There is 
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no practical difference between icc and icm files. Custom profiles for monitors, printers, and 

scanners are usually (but not always) put in this folder.  

A.14 Targets for Making Color Profiles 

The targets used to make color profiles for scanners vary in quality. A target has an 

associated target description file that contains the precise measurements for each color patch on 

the target. Expensive targets have the target description measurements done for each individual 

target. Inexpensive targets are produced in batches and have the target description 

measurements based on the average of a sample for a batch rather than based on specific 

measurements for each target. Individual measurements for targets can be significantly more 

accurate than the batch measurements (Fraser, Murphy, and Bunting, 2005, page 148). Of 

course, the inexpensive targets still produce better results than no color management and may be 

adequate for many situations when the primary goal is to produce acceptable prints and 

reasonably consistent images for display on a computer. 

The website for Wolf Faust (http://targets.coloraid.de) is one of the least expensive sources 

for IT8 targets ($10 for a reflective target and/or $25 to $75 for a slide target plus $10 for 

shipping). These targets are widely used. The LaserSoft company 

(https://www.silverfast.com/order/en.html ) has relatively inexpensive targets ($33 to $195 

plus shipping) and other targets that are individually measured ($180 to $330 plus shipping). 

Targets can also be obtained from other sources. 

A.15 How to Determine What Software is Actually Doing 

The most reliable source of information about the implementation of color management for 

specific software is to do basic investigations and experiments with the software. Unfortunately, 

most software currently does not fully and properly implement color management, and the 

marketing of the software tends to be ambiguous about the limitations. My experience has also 

been that software support often provides ambiguous responses to questions about color 

management. Methods for directly determining how color management is being handled are very 

useful. 

The PhotoME Program 

The free PhotoME program (Duttke, 2009) displays the EXIF metadata in an image and 

information about an embedded color profile. The embedded profile information includes 

http://targets.coloraid.de/�
https://www.silverfast.com/order/en.html�
http://www.photome.de/�
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whether it is a matrix or lookup table profile and what rendering intents are provided. The 

program can be used with profile files alone or with profiles embedded in an image file. On the 

PhotoME display for an image file, a tab at the top labeled ICC Profile has information about an 

embedded profile. This tab is missing if the file does not have an embedded profile. On my 

computer, opening the ICC Profile section for a large TIFF file sometimes takes a very long time. 

The computer appears to be hung up but eventually returns with the information. 

Under the ICC Profile tab, matrix profiles will have a row with “Red Tone Reproduction 

Curve” in the Field column and “rTRC” in the Tag column. Similar rows will be present for green 

and blue.  

A lookup table profile will have rows with values such as “A to B0” in the Field column and 

“A2B0” in the Tag column. The column for Data Format will typically be “Lut16” or possibly 

“Lut8”. These rows indicate lookup tables for specific rendering intents. “A to B0” is for 

perceptual, “A to B1” is for both relative and absolute colorimetric, and “A to B2” is for 

saturation. Profiles for printers and other output devices have additional types of lookup table 

rows. A lookup table profile may include a matrix with rows for rTRC, gTRC, and bTRC. A pure 

matrix profile will have no lookup table rows. Some lookup table profiles have rows or tables for 

only one or two rendering intents. 

The PhotoME program can also display a graphic representation of the color space for matrix 

profiles. The graph shows an outline of the profile color space against a U-shaped background 

that represents all the colors the human eye can see. Standard working color spaces such as 

sRGB and Adobe RGB can also be displayed on the graph for comparison. The graphical profile 

display is opened by clicking the ICC Profile tab and then clicking the round color icon on the 

right side of the ICC Profile header line. 

The EXIF data is displayed by clicking the Camera tab. If InteroperabilityIndex data is 

provided, there will be a tab for Interoperability. 

The PhotoME program can be very valuable when color management is used with a variety of 

devices, software, and working color spaces. Use of the program is probably not necessary if the 

only working color space being used is sRGB, or if all images have the working color space 

carefully set in an image editing program such as Photoshop CS. 

Investigating Output Files 

The PhotoME program provides essential information about embedded profiles and EXIF data 

in image files. Many unexpected results can be identified by examining the embedded profile and 

EXIF data.  
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The methods described earlier in Section A.3 on misleading rendering intent choices are also 

very useful for investigating output files. Images that should be the same or that should be 

different can be compared easily and precisely with these methods. 

Investigating the use of Color Profiles 

Microsoft has prepared a special test image and profile for testing if software properly reads 

and applies standard ICC profiles. The profile switches the blue and green color channels if 

software properly applies standard ICC color profiles. If the software applies the WSC profiles 

developed by Microsoft, the blue and red channels are switched. An image with the special 

profile embedded is provided for testing. The image has a motorcycle that is green if the 

embedded ICC profile is used and is red if the WSC profile is used. The motorcycle is blue if the 

displaying software does not use an embedded profile. The image and profile are in the file 

“WSC_Profile_Utilization_Test_Image_and_Profile.zip” which can be downloaded from Microsoft 

Corporation (2006). The profile file is named BGR-Wcs-RBG-Icc-Test.icc. 

The special test profile can be used for a variety of definitive tests of image-processing 

software. I found it more useful to make my own test image that had blue, green, and red strips 

with the color written in text on each strip. When the special test profile is embedded with the 

test image, opening the image in image-processing software quickly indicates if the embedded 

profile is being used. The color strips labeled blue and green will be switched if the ICC profile is 

used. The red and blue strips will be switched if the WSC profile is used. The blue and green 

strips remain as labeled if the test profile is not applied. The test image can be downloaded 

from http://archivehistory.jeksite.com/download/download.htm. 

The test profile also can be assigned as the monitor profile for testing software. The profile 

can be assigned in the configuration of color management software such as VueScan and XnView 

that require assignment of a specific monitor profile. The test profile can be assigned as the 

default monitor profile for the operating system to test whether software such as Photoshop and 

SilverFast properly obtain and apply the default system monitor profile. The test image without 

an embedded profile or with the usual sRGB profile embedded can be used to test whether the 

assigned monitor profile is actually being used.  

The test profile can also be assigned as the working color space to determine whether the 

appropriate profile is used to create an output image. The difference between assigning and 

converting color space can be clearly seen. The test profile can be embedded in an image file 

using Photoshop CS or using the free XnView image viewer. With XnView, set the monitor profile 

to be the test profile. The monitor profile will be embedded when an output image is saved. 

Appendix E provides more information about using and configuring XnView.  

http://blogs.msdn.com/b/color_blog/archive/2006/09/29/profile-utilization-test-image-and-profile.aspx�
http://blogs.msdn.com/b/color_blog/archive/2006/09/29/profile-utilization-test-image-and-profile.aspx�
http://archivehistory.jeksite.com/download/download.htm�


A-22 
 

The test image can be printed and then scanned to test scanning software. 

The ability to predict when the blue strip will be green or red and when it will be blue is a 

good indication of a person’s understandings of both color management and the software that is 

being used. The actual operation of image-processing software can be very different than 

expected. 

Investigating the Monitor Profile LUT 

The application of the LUT in the monitor profile can be investigated by developing a special 

monitor profile with a strong color cast. I set the manual settings on my monitor to have high 

levels of green and blue and low levels of red. Then the X-Rite One-Eye profiling device and 

software were used to make a profile for the monitor. When the color settings for the monitor 

were returned to normal, the resulting profile had a strong pink colorcast, particularly for light 

gray colors. Pure white did not show the colorcast. This test profile can be downloaded 

from http://archivehistory.jeksite.com/download/download.htm. 

This profile can be used to explore and understand the LUT for the monitor. When the test 

profile is set as the system default, the fact that the LUT applies to everything displayed on the 

monitor is obvious. Potential issues in writing or updating the LUT information to the video card 

also become apparent, as discussed in the next section. 

This test profile also can be assigned as the monitor profile in certain image-processing 

software and can be embedded in image files to explore how the LUT settings are handled in 

these cases. The distinction between using a color profile for color conversions and using the LUT 

for the monitor becomes apparent.   

A.16 Applying the LUT in a Monitor Profile 

The lookup table in a monitor color profile needs to be transferred to the video card for the 

monitor. This is typically done when a computer boots up. The software that creates the profile 

usually has an option for a small program to run to read and write the LUT information. The 

Windows 7 operating system also has an option to read and write the monitor LUT information. 

My experience has been that the Windows 7 option executes more reliably than the program 

from the software that creates the profile. The Windows 7 option is more reliable when the 

default profile is changed without rebooting and when power management options such as 

hibernation are used. 

 The programs from the profiling software are often automatically run from the startup folder 

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup. The program file can be 

http://archivehistory.jeksite.com/download/download.htm�
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turned off by removing it from this folder. Alternatively, a system-cleaning program such as the 

free CCleaner program can be used to disable the program. The use of CCleaner provides the 

option to easily enable the program later if needed. In CCleaner, a startup program is disabled by 

clicking on the Tools icon and then the Startup button. Right-click on the row with the program 

and select Disable. 

The Windows 7 option to load the monitor LUT can be turned on or off by right-clicking 

anywhere on the desktop and selecting Screen Resolution. Click the Advanced Settings link on 

the right, and then the Color Management tab and then the Color Management button. The 

default color profile for the monitor can be set from this screen. Click the Advanced tab and then 

the button at the bottom for “Change system defaults.” On the next screen click the Advanced 

tab, and then click the check box at the bottom for “Use Windows display calibration.” When this 

box is checked, Windows will automatically load the LUT for the monitor, and reload as needed. 

A.17 Inner Workings of Color Management 

In order to accurately convert color spaces, a standard reference color space needs to be 

defined. The CIE color system was developed to model typical human vision and is used as the 

PCS (Profile Connection Space) that is the reference standard for color management.  

The color profile for an input device like a scanner specifies how to convert the scanner color 

space to the PCS. The profile for an output device like a printer specifies how to convert the PCS 

to the color space for the printer. The profile for a working color space such as sRGB must be 

able to go in either direction, to or from the PCS.  

Matrix profiles are equations that can directly convert in either direction. However, lookup 

table profiles need separate tables for converting to and from the PCS, as well as for each 

rendering intent. This makes the distinction between input and output profiles important when 

applying profiles. Many printer profiles have tables for both directions.  

In a lookup table profile, a tag or field name that is “A2B” or “A to B” indicates a table that 

converts the device color space to the PCS. A tag or field name that is “B2A” or “B to A” indicates 

a table that converts from the PCS to the device color space. The additional codes of 0, 1, and 2 

are for the perceptual, colorimetric, and saturation rendering intents as noted above.  

The application of this general strategy involves many details and distinctions, such as that 

the CIE color system actually includes two different standard color space models (CIE XYZ and 

CIE LAB) that can be used as a PCS. 
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